The dripstone mod has been accepted on ContentDB. It can now be safely assumed that the dripstone
namespace is reserved for this mod.
It's just a constant difference though - so just like the h
value, I'm more than happy to change the value to 4w + 2
or even 2w + 1
.
I think you're forgetting to square the 2:
2(w + 1) * 2(w + 1) * h - 2w * 2w * h
4(w + 1)² * h - 4w² * h
... rewrites to ...
h(4(w+1)² - 4w²)
h(4(w² + 2w + 1) -…
While noordstar_dripstone.add_droplet_source
is an explicit declaration that a node can create droplets, using secondary features such as liquidity and group names is an implicit declaration.…
In this case, we're dealing with truthy values and I'm not sure if it improves readability.
Also, wouldn't this return false
instead of nil
?
As per the function internal.nodebox_of_size(w)
, the width of the nodebox of size w
is 2*w
. As a result, the volume of a dripstone node of size w
is 2w*2w*h
.
So in order to grow from…
I have several reasons why I implemented it this way:
- The code contribution guidelines states to not declare functions as an assignment.
- The method adds extra security. Exposed functions can…
I've finished the refactor which removes most of the repetition, and makes the mod a lot more customizable. Here's the [updated API documentation with images](https://git.noordstar.me/Bram/dripston…
I've spent some time considering the options, and I might know a way to make the code less repetitive. I am working on a refactor.
Most of the feedback looks good, and I will update the code accordingly.
I'm a bit skeptical of implementing tables through which can be looped in order to avoid repetition. The dripstone has a…